Welcome to The Few Good Men

Thanks for visiting our club and having a look around, there is a lot to see. Why not consider becoming a member?

Fix For Blurry Text and Incorrect Render Resolution

Longbow

FGM New Member
FGM MEMBER
Joined
Feb 1, 2021
Messages
2
Age
26
Location
Florida
Hello,

I'm new to the forums, so if this is in the wrong place or has already been answered somewhere (I couldn't find it after some extensive searching) please let me know.

After getting into CM recently, I noticed an issue I was having with the resolution the game was displaying at. This manifested itself as blurry text and major aliasing on textures and models. The in-game setting for display size and changing the setting manually in the text file in the CM root directory did not seem to solve this problem.

I later was able to confirm that the game was running at the wrong resolution by taking a steam screenshot and opening the screenshot properties in Windows. This showed that the resolution of the screenshot (which is set to take full resolution images) was 2048x1152. My monitor runs at 2560x1440.

I attempted to find a solution to this online, searching this forum and beyond, to no success. Today, I remembered the old Windows display scaling option and gave that a try. To my surprise, this fixed the issue for me immediately.

Specifically, go to the CM root directory,

find the application for the game (I tested this with SF2 and BS but I assume it will work with all title using this engine) and right click,

click on 'Properties',

click on the 'Compatibility' tab,

click on 'Change High DPI Settings',

at the bottom of the next popup under 'High DPI Scaling Override' click the checkbox
- side note: the default 'Application' setting in the dropdown worked for me but you may need to try some of the other options depending on your specific system

click 'Ok' to close the second popup and save your settings,

click 'Ok' again to close the first popup and save your settings,

play the game!


After making this change I verified it had worked (besides the obvious of having clear text and models) by taking another screenshot and seeing that it indeed captured at 2560x1440.

The only side effect of this change is that text is effectively slightly smaller, as it is being rendered at a higher resolution on the same sized screen. Personally, I would take smaller, clear text (not to mention clearer in-game models) over larger, blurry text any day!

Hopefully this is helpful for some of you, if further explanation or images are needed let me know and I'll be happy to help!

Again, if I put this in the wrong place or if there is already a good explanation of this that I missed I apologize in advance!
 

Elvis

FGM New Member
FGM MEMBER
Joined
Feb 12, 2019
Messages
2
Age
61
Location
Pennsylvania
The most common reason for blurry text is a computer (usually a laptop) running the games on an Intel integrated video card. If you're one of those people and have a dedicated video card, in addition to Intel card, set your video card to run on high performance graphics. I forget offhand how to do it with a Radeon card (I usually have to Google it) but I need to do it sometimes with my laptop and my GeForce card. It's pretty quick and simple. Right click the Desktop, select NVIDIA Control Panel. Under 3D Settings (Global) use the drop down menu and select high performance graphics. Sometimes it reverts back to the Intel card after a Windows Update.
 
Top